ZTE ZXA10 C220 OLT NM Configuration

ZTE ZXA10 C220 OLT NM Configuration

ZTE ZXA10 C220 OLT NM Configuration

Today i will discuss about ZTE ZXA10 C220 OLT NM Configuration.

ZXA10 C220 supports both in-band NM and out-of-band NM.

  • In-band NM is implemented through uplink port. It is usually used in practical engineering.
  • Out-of-band NM is implemented through the Q port on the control switching card. It is usually used in local management.

Configuring In-Band NM:

Prerequisites:

  • Make sure the network device works normally.
  • Log in to the ZXA10 C220 through HyperTerminal/Xshell/Putty.

Background Information:

In the in-band NM mode, NMS information is transmitted through service channel of ZXA10 C220. It is flexible in networking without any auxiliary devices, and low in cost. But it is hard to maintain ZXA10 C220 when the service is down.

Network Diagram Sample: Bellow are the in-band NM networking diagram.

ZTE ZXA10 C220 OLT NM Configuration

ZTE ZXA10 C220 OLT NM Configuration

Configuration Data:

ZXA10 C220 in-band NM interface

  • VLAN ID: 1000
  • Port: 0/14/1
  • IP address: 10.67.1.10/24

Router interface

  • IP address: 10.67.1.254/24

SNMP server host

  • IP address; 10.63.10.105/24
  • Version: V2C
  • Community: private
  • Alarm: NOTIFICATIONS

The corresponding data must be configured on the router as well.

To configure the in-band NM, perform the following steps:

Step-1: Configure in-band NM VLAN.

i. Enter global configuration mode.

ZXAN#configure terminal
Enter configuration commands, one per line. End with CTRL/Z.
ZXAN(config)#

ii. Enter uplink interface configuration mode.

ZXAN(config)#interface gei_0/14/1
ZXAN(config-if)#

iii. Add uplink port to NM VLAN in tag mode.

ZXAN(config-if)#switchport vlan 1000 tag
ZXAN(config-if)#exit
ZXAN(config)#

Note: When a port is added to a VLAN, the VLAN is added automatically.

Step-2: Configure IP address of in-band NM interface.

i. Enter VLAN interface configuration mode.

ZXAN(config)#interface vlan 1000
ZXAN(config-if)#

ii. Configure IP address of in-band NM interface.

ZXAN(config-if)#ip address 10.67.1.10 255.255.255.0
ZXAN(config-if)#exit
ZXAN(config)#

Note: In-band NM IP address and out-of-band NM IP address must not be in the same network segment.

Step-3: Configure in-band NM route.

ZXAN(config)#ip route 10.63.10.0 255.255.255.0 10.67.1.254

Step-4: Configure SNMP community.

There is a default public community in the system. To configure other community, use the snmp-server community
command. Refer to .

Step-5: Configure SNMP server (Trap server).

ZXAN(config)#snmp-server host 10.63.10.105 trap version 2c private enable NOTIFICATIONS server-index 1 udp-port 162

Note: When there is trap server from other vendors besides ZTE NetNumen NMS, multiple snmp-server hosts can be configured.

Step-6: Configure Trap types (optional).

ZXA10 C220 supports six types of traps: SNMP, BGP, OSPF, RMON, STALARM, VPN. All traps are enabled by default.

ZXAN(config)#snmp-server enable trap
ZXAN(config)#exit
ZXAN#

Step-7: Save configuration data.

ZXAN#write
Building configuration…
…[OK]

Result: The ZXA10 C220 can be managed through the in–band NM IP address.

Configuring Out-of-Band NM:

Prerequisites:

  • Make sure network device works normally.
  • Log in to the ZXA10 C220 through HyperTerminal/Xshell/Putty.

Background Information:

  • In the out-of-band NM mode, NMS information is transmitted through non-service channel. The management channel is independent from the service channel. Thus out-of-band NM is more reliable comparing with the in-band NM.

Networking Diagram:  Bellow are the ZTE ZXA10 C220 OLT NM Configuration out–of-band NM networking diagram.

ZTE ZXA10 C220 OLT Out-of-Band NM Configure

ZTE ZXA10 C220 OLT Out-of-Band NM Configure

Configuration Data:

ZXA10 C220 out–of-band NM interface

IP address: 136.1.1.100/24

Router interface IP address: 136.1.1.254/24

SNMP server host

  • IP address; 10.63.10.105/24
  • Version: V2C
  • Community: private
  • Alarm: NOTIFICATIONS

To configure the out-of-band NM, perform the following steps:

Step-1: Configure out-of-band NM IP address.

i. Enter the global configuration mode.

ZXAN#configure terminal
Enter configuration commands, one per line. End with CTRL/Z.
ZXAN(config)#

ii. Configure out-of-band NM IP address.

ZXAN(config)#nvram mng-ip-address 136.1.1.100 255.255.255.0

Note: In-band NM IP address and out-of-band NM IP address must not be in the same network segment.

Step-2: Configure out-of-band NM route.

ZXAN(config)#ip route 136.1.1.0 255.255.255.0 136.1.1.254

Step-3: (Optional) Configure SNMP community.
There is a default public community in the system. To configure other community, use the snmp-server community
command.

ZXAN(config)#show snmp config
snmp-server location xxxxx, yyyyy, zzzzzzz, Bangladesh.
snmp-server contact +88-017-xxxxxxxx
snmp-server packetSize 3000
snmp-server engine-id 830900020300010289d64401
snmp-server community public view allview rw
snmp-server view allview internet included
snmp-server view DefaultView system included
snmp-server enable trap SNMP
snmp-server enable trap VPN
snmp-server enable trap BGP
snmp-server enable trap OSPF
snmp-server enable trap RMON
snmp-server enable trap STALARM

Step-4: Configure SNMP server (Trap server).

ZXAN(config)#snmp-server host 10.63.10.105 trap version 2c private enable NOTIFICATIONS server-index 1 udp-port 162

Note: When there is trap server from other vendors besides ZTE NetNumen NMS, multiple snmp-server hosts can be configured.

Step-5: Configure Trap types (optional).

ZXA10 C220 supports six types of traps: SNMP, BGP, OSPF, RMON, STALARM, VPN. All traps are enabled by default.

ZXAN(config)#snmp-server enable trap
ZXAN(config)#exit
ZXAN#

Step-7: Save configuration data.
ZXAN#write
Building configuration…
…[OK]

Result: The ZXA10 C220 can be managed through the out-of-band NM IP address.

email

Shahed

Hi! I am Shahed. I currently work as a Sr. Network Engineer. I want to build up my carrier in Networking field.

Follow Me:
TwitterFacebookLinkedInPinterestGoogle PlusDiggYouTubeRedditDelicious

ZTE ZXA10 C220 OLT NM Configuration was last modified: March 17th, 2016 by Shahed

Comments

comments

Leave a Reply

Your email address will not be published. Required fields are marked *

Time limit is exhausted. Please reload CAPTCHA.

error: Content is protected !!