March 29, 2024

BGP Multihoming with Two Different ISP

BGP Multihoming:

[boxads]Today i will discuss how to configure BGP Multihoming with Two Different Service Providers environment. When you connect your network to two different Internet service providers (ISPs), it is called multihoming. Multihoming provides redundancy and network optimization. It selects the ISP which offers the best path to a resource. So let’s follow our diagram:

BGP Multihoming
BGP Multihoming

Here Router R1 upstream are connected to two ISP’s. one is ISP-1 and AS is 100, another is ISP-2 and it’s AS is 200. Now let’s go our BGP Multihoming configuration part.

BGP Multihoming Configuration Example:

Configuration of Router R1:
R1#conf t
R1(config)#int loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#int loopback 1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#int loopback 2
R1(config-if)#ip address 192.168.2.1 255.255.255.0
R1(config-if)#exi
R1(config)#int fa0/1
R1(config-if)#ip address 172.16.10.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#int fa0/0
R1(config-if)#ip address 172.16.20.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#ip route 20.20.20.20 255.255.255.255 172.16.20.2
R1(config)#ip route 10.10.10.10 255.255.255.255 172.16.10.2

R1(config)#router bgp 300
R1(config-router)#neighbor 10.10.10.10 remote-as 100
R1(config-router)#neighbor 10.10.10.10 update-source loopback 0
R1(config-router)#neighbor 10.10.10.10 ebgp-multihop 2
R1(config-router)#neighbor 20.20.20.20 remote-as 200
R1(config-router)#neighbor 20.20.20.20 update-source loopback 0
R1(config-router)#neighbor 20.20.20.20 ebgp-multihop 2
R1(config-router)#network 192.168.1.0 mask 255.255.255.0
R1(config-router)#network 192.168.2.0 mask 255.255.255.0

[adsense]

Configuration of ISP-1 Router:

ISP-1#conf t
ISP-1(config)#int fa0/1
ISP-1(config-if)#ip address 172.16.10.2 255.255.255.252
ISP-1(config-if)#no shutdown
ISP-1(config-if)#exit
ISP-1(config)#int loopback 0
ISP-1(config-if)#ip address 10.10.10.10 255.255.255.255
ISP-1(config-if)#exit

ISP-1(config)#ip route 1.1.1.1 255.255.255.255 172.16.10.1

ISP-1(config)#router bgp 100
ISP-1(config-router)#neighbor 1.1.1.1 remote-as 300
ISP-1(config-router)#neighbor 1.1.1.1 update-source loopback 0
ISP-1(config-router)#neighbor 1.1.1.1 ebgp-multihop 2
ISP-1(config-router)#network 10.10.10.10 mask 255.255.255.255

Configuration of ISP-2 Router:

ISP-2#conf t
ISP-2(config)#int loopback 0
ISP-2(config-if)#ip address 20.20.20.20 255.255.255.255
ISP-2(config-if)#int fa0/0
ISP-2(config-if)#ip address 172.16.20.2 255.255.255.252
ISP-2(config-if)#no shutdown
ISP-2(config-if)#exit

ISP-2(config)#ip route 1.1.1.1 255.255.255.255 172.16.20.1

ISP-2(config)#router bgp 200
ISP-2(config-router)#neighbor 1.1.1.1 remote-as 300
ISP-2(config-router)#neighbor 1.1.1.1 update-source loopback 0
ISP-2(config-router)#neighbor 1.1.1.1 ebgp-multihop 2
ISP-2(config-router)#network 20.20.20.20 mask 255.255.255.255

BGP Multihoming Verification:

If we show ISP-1 routing table by show ip route then we see:

BGP route from ISP-1
BGP route from ISP-1

Here we see R1 & ISP-2 both BGP route also we found it our BGP table. so our configuration is ok. now i ping test from ISP-1 to ISP-2, so lets go……….

ISP-1 ping report
ISP-1 ping report

Here when we normal ping ISP-2 loopback ip then we didn’t get ping as a cause of we didn’t advertise point-to-point 172.16.x.x series ip. but when we ping with loopback source then we got ping, because our loopback reach ability is ok. If we want to ping directly without loopback source then we need to advertise both interface network in R1 BGP section, by network command or redistribute command. here we configure by redistribute command.

R1(config)#router bgp 300
R1(config-router)#redistribute connected

Now we look ping status ISP-1:

ISP-1#ping 20.20.20.20
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.20.20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 96/112/128 ms
ISP-1#

Now we see R1 BGP table:

BGP summary of R1
BGP summary of R1

Here we found both ISP’s route in BGP but RIB failure, it is not problem. we avoid this RIB failure by manually increase static route AD value greater than 20 because eBGP AD value 20. Lets enjoy your BGP Multihoming Lab.

Shahed

Hi! I am Shahed Israr. I try to help GPON Technology users with their queries and provide them with relevant and accurate information to the best of my ability. My main goal is to assist and enhance GPON Technology user and help people find the answers they're looking for quickly and easily.

Follow Me:
TwitterFacebookLinkedInPinterestGoogle PlusDiggYouTubeRedditDelicious

Visited 304 times, 1 visit(s) today

Comments

comments

Shahed

Hi! I am Shahed Israr. I try to help GPON Technology users with their queries and provide them with relevant and accurate information to the best of my ability. My main goal is to assist and enhance GPON Technology user and help people find the answers they're looking for quickly and easily.

View all posts by Shahed →

Leave a Reply

Your email address will not be published. Required fields are marked *

Time limit is exhausted. Please reload CAPTCHA.

error: Content is protected !!