eBGP load balancing with single-homed BGP environment

eBGP load balancing with single-homed BGP environment

eBGP load balancing :

Today i will discuss how to configure eBGP load balancing with single-homed BGP environment. So lets go…….. If we look our topology we see here two ISP router are connected through two link.  Also this two router are in different autonomous system. Router R1 autonomous system is 21 & Router R2 autonomous system is 22.

Router R1 loopback address: 1.1.1.1  & 11.11.11.11

Router R2 loopback address: 2.2.2.2 & 12.12.12.12

Also this loopback0 are connected via static route & loopback1 connected via eBGP.

eBGP load balancing Network Diagram:

eBGP load balancing

eBGP load balancing

This scenario shows how to achieve load balancing when there are multiple (up to a maximum of six), equal-cost links. The links are terminated in one router at a local autonomous system (AS) and in another router at a remote AS in a single-homed BGP environment. Now we will be start our configuration part.

Router R1 Configuration:

Basic IP Configure:

R1#configure terminal
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config)#interface loopback 1
R1(config-if)#ip address 11.11.11.11 255.255.255.0
R1(config-if)#int fa0/0
R1(config-if)#ip address 10.10.0.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#int fa0/1
R1(config-if)#ip address 10.10.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#

Static Route Configure:

R1(config)#ip route 2.2.2.2 255.255.255.255 10.10.1.2
R1(config)#ip route 2.2.2.2 255.255.255.255 10.10.0.2

BGP Configure:

R1(config)#router bgp 21
R1(config-router)#neighbor 2.2.2.2 remote-as 22
R1(config-router)#neighbor 2.2.2.2 update-source loopback 0
R1(config-router)#neighbor 2.2.2.2 ebgp-multihop 2
R1(config-router)#network 1.1.1.1 mask 255.255.255.255
R1(config-router)#network 11.11.11.0 mask 255.255.255.0

Router R2 Configuration:

Basic IP Configure:

R2#configure terminal
R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config)#interface loopback 1
R2(config-if)#ip address 12.12.12.12 255.255.255.0
R2(config-if)#int fa0/0
R2(config-if)#ip address 10.10.0.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#int fa0/1
R2(config-if)#ip address 10.10.1.2 255.255.255.0
R2(config-if)#no shutdown

Static Route Configure:

R2(config)#ip route 1.1.1.1 255.255.255.255 10.10.0.1
R2(config)#ip route 1.1.1.1 255.255.255.255 10.10.1.1

BGP Configure:

R2(config)#router bgp 22
R2(config-router)#neighbor 1.1.1.1 remote-as 21
R2(config-router)#neighbor 1.1.1.1 update-source loopback 0
R2(config-router)#neighbor 1.1.1.1 ebgp-multihop 2
R2(config-router)#network 2.2.2.2 mask 255.255.255.255
R2(config-router)#network 12.12.12.0 mask 255.255.255.0

Verify:

When we put show ip route command in Router R1 then 2.2.2.2 network are learned via both static route but 12.12.12.0 network are learned via eBGP, but why r you know ? now i describe  it, our both loopback ip connected via eBGP peering but loopback 0 also connected via static route. As per rule static route administrative distance value  is 1 & eBGP AD value is 20, that causes 2.2.2.2 network got via static route because lowest AD value. If we want to learn 2.2.2.2 network via eBGP then we need to increase static route AD value manually  greater-than 20.  The output of the traceroute command indicates that the load is distributed between two path. In this scenario, load sharing occurs on a per-packet basis. You can also configure per-packet and per-destination load balancing with Cisco Express Forwarding.

verify eBGP load balancing

verify eBGP load balancing

When we look bellow BGP table then we see  network 2.2.2.2 is RIB failure, but 12.12.12.0 network is valid & best. this rib failure is not problem but you can solved this by increase static route AD value manually  greater-than 20.

Show ip bgp

Show ip bgp

email

Shahed

Hi! I am Shahed. I currently work as a Sr. Network Engineer. I want to build up my carrier in Networking field.

Follow Me:
TwitterFacebookLinkedInPinterestGoogle PlusDiggYouTubeRedditDelicious

eBGP load balancing with single-homed BGP environment was last modified: February 11th, 2015 by Shahed

Comments

comments

Leave a Reply

Your email address will not be published. Required fields are marked *

Time limit is exhausted. Please reload CAPTCHA.

error: Content is protected !!